**Reel Slots** Gaming Machines > IGT S and S-plus Reel Games

IGT Triple Diamond Problems

(1/3) > >>

This is a machine my brother purchased many years back. When he gave it to me, we ended up having to do a clear, put in a new battery and then it worked, for about a year.

However, a few months ago, it stopped working. When you put a quarter in, it wouldn't do anything. Hadn't used it for several months since then. However, tried to see what I could do, to fix it, this evening.

Went a got a brand new battery and that got me to Code 61 1. I pressed the reset button, closed the door, etc..., but it never moved from that code. I then tried the clear chip and it let me pull the handle some, but that's about it. I then put the game chip back in and I can't get anything now. The red screen shows nothing, pressing reset does nothing.

I am a complete novice at fixing the thing, so any help would be much appreciated.

Scroll to the bottom of the page on this link...>>>


My problem is that once I did the clear chip and then the game chip, I am getting nothing on the screen...not even the 61-1

Pull the SP GAME chip out of the socket slowly, you may have folded a PROM leg underneath the chip body, instead of inserting it into the socket hole.

The orientation of the chip's direction is important as well.
The indentation on top of the SP chip body should face the etched marking on the MPU circuit board that says "GAME PROM".

Thanks...I just tried that (had the chip the wrong way), but still nothing.


[0] Message Index

[#] Next page

Cell Phone and Pad Mode

imode wap wap2

NLG Archives

Archives @ newlifegames.net Wayback Machine

Contact Us

NLG Shop 928 754-4147 Email Us 1788 Highway 95 30 BHC City AZ 86442
Go to full version